kali MSF启动失败:Run `bundle install` to install missing gems.


如果你启动MSF时提示错误:

Run bundle install to install missing gems.

可能就是因为缺少依赖库。
把下面这些全部输入执行一遍,99%问题都解决了。

gem update --system
bundler gem install bundler -v 2.1.4
apt-get install ruby-dev
apt-get install postgresql
apt-get install libpcap-dev
apt-get install oracle*
apt-get install libsqlite3-dev
然后我们终端进入Metasploit所在目录(cd /usr/share/metasploit-framework/),执行bundle install
去安装 bundle install,然后就可以顺利启动。
(没图是因为我已经安装好了,只是存份笔记,以便再用)

声明:苏茗鹿的空间|版权所有,违者必究|如未注明,均为原创|本网站采用BY-NC-SA协议进行授权

转载:转载请注明原文链接


Carpe Diem and Do what I like